Unexpected exception when running "hal deploy apply"


#1

After updating halyard tonight, I’m now getting this error when trying to set up a new installation (using the same steps as before. This is a local installation configuration that has worked elsewhere.

Any idea as to where I can look for troubleshooting on this?


#2

sudo hal -q -l debug deploy apply generates no further useful information. The only warnings I’m getting are about no validation for the AWS account info, which is normal (as far as I know).


#3

hal -v output is 1.9.1-20180830145737


#4

I tried restoring a backup from another (older) installation and got the same error when trying to apply with halyard 1.9.1 - is there any way to downgrade Halyard?


#5

Uninstalling halyard and re-running InstallHalyard.sh --version 1.7.0, then running sudo hal deploy apply worked.


#6

Ran into the same issue above, but it appears I needed to specify a region. I ran these commands and it started to work. Not digging to much but it appears to be an issue either with not passing regions or no validation passing. Hope this helps.

hal -v
1.9.1-20180830145737

hal config provider aws account delete demo-aws
hal config provider aws account add build --account-id --assume-role role/spinnakerManaged --regions us-west-2 --no-validate


#7

Thank you, will let you know!


#8

That was it, thank you very much!!!