Unable to deploy Manifests using Kubernetes V2 Provider


#1

Hi,

We have deployed OpenSource Spinnaker on Openshift 3.6 (kubernetes 1.6) using halyard. I have installed halyard on Ubuntu 16.0.

Here is the list of versions we are using.

  • Kubernetes -1.6
  • Halyard -1.3.1
  • Spinnaker - 1.8

Currently we are facing these issues:-

  1. We doesn’t have cluster admin privileges and we were given permission to list the namespaces by the
    admin team. we were not granted the permissions mentioned in
    https://www.spinnaker.io/setup/install/providers/kubernetes-v2/#optional-configure-kubernetes-roles-rbac

  2. When deploying Manifests using V2 provider. we are getting the error as “Error from Server (Forbidden)
    Unknown”

  3. When I check the clouddriver logs I see the error as

    2018-07-19 17:17:37.011 WARN 1 — [tionAction-1117] c.n.s.c.k.v.c.a.KubernetesV2CachingAgent : Failed to read kind [clusterRole, clusterRoleBinding, configMap, controllerRevision, customResourceDefinition, cronJob, daemonSet, deployment, event, horizontalpodautoscaler, ingress, job, pod, replicaSet, role, roleBinding, namespace, networkPolicy, persistentVolume, persistentVolumeClaim, secret, service, serviceAccount, statefulSet] from namespace coi-management-poc: Failure running list on [clusterRole, clusterRoleBinding, configMap, controllerRevision, customResourceDefinition, cronJob, daemonSet, deployment, event, horizontalpodautoscaler, ingress, job, pod, replicaSet, role, roleBinding, namespace, networkPolicy, persistentVolume, persistentVolumeClaim, secret, service, serviceAccount, statefulSet]: error: the server doesn’t have a resource type “controllerRevision”

  4. Our Kubernetes server version is 1.6, our cluster admins are not willing to upgrade the cluster version.

  5. Can I know the minimum version of kubernetes cluster that halyard and spinnaker supports?

Any help on solving this issue will be appreciated. Thank you.


#2

Hi @harika2724 I’ve responded on the related Github issue here: https://github.com/spinnaker/spinnaker/issues/3065