Spinnaker not listing all artifact accounts


#1

I’ve added a Docker Hub account and a GitHub account, and when I try to create a server group I only see the GitHub account as an option for getting artifacts. I clearly see the Docker Hub account info, all accurate and including my repository, in hal config, but I can’t select it when I create a new server group for my application. Any idea of what might be wrong? I’m using the latest Spinnaker master build.


#2

When you created the kubernetes account in hal, did you specify version two as specified here? I had trouble adding quay until I did that.


#3

Thanks @rhuffman. I just checked and I get

      providerVersion: V2

from hal config.


#4

Although it doesn’t say it in the V2 provider, you may need to manually add your docker registry to your kubernetes provider. A combined command might look like this in halyard:

   hal config provider kubernetes account edit [your kube acct] \
    --provider-version v2 \
    --context $(kubectl config current-context)
    --docker-registries [the name of your configured docker registry]

#5

Thanks! Tried that and now in hal config I get:

  kubernetes:
    enabled: true
    accounts:
    - name: my-k8s-v2-account
      requiredGroupMembership: []
      providerVersion: V2
      permissions: {}
      dockerRegistries:
      - accountName: my-docker-registry
        namespaces: []
      context: ben
      configureImagePullSecrets: true
      cacheThreads: 1
      namespaces: []
      omitNamespaces: []
      kinds: []
      omitKinds: []
      customResources: []
      cachingPolicies: []
      kubeconfigFile: /Users/bklein/.kube/config
      oauthScopes: []
      oAuthScopes: []
    primaryAccount: my-k8s-v2-account

But still no Docker Hub in the Artifact Account dropdown when I go to create a server group for my application.


#6

Can you post a screenshot of what you’re seeing? I’m unclear where in the UI you’re looking.