Spinnaker keeps on spinning when I hit Create Application

I’m using Quick Start which intern uses AWS Cloud Formation to make Spinnaker Up and Running in AWS on m4Large EC2 instance.

I’ve done SSH tunnelling to access Spinnaker DECK UI from my mac. When I hit localhost:9000 UI is shown. But when I tried to create application, the spinner keeps on spinning.

I’ve inspected the logs : /opt/Spinnaker/logs
It’s throwing Exception :
java.net.ConnectException: Failed to connect to localhost/

I’ve also seen the following exception:

Exception :



Parameter 0 of constructor in com.netflix.spinnaker.front50.graphql.datafetcher.PipelinesDataFetcher required a bean of type ‘com.netflix.spinnaker.front50.model.pipeline.PipelineDAO’ that could not be found.
- Bean method ‘redisPipelineDAO’ not loaded because @ConditionalOnExpression (#{${spinnaker.redis.enabled:false}}) resulted in false


Consider revisiting the conditions above or defining a bean of type ‘com.netflix.spinnaker.front50.model.pipeline.PipelineDAO’ in your configuration.

How can I resolve this issue?

@Rajesh_Waran: My guess based on the error message is that you haven’t configured external storage as documented here. Front50 requires some external storage in order to store pipelines (and other data), and is failing to start up due to the lack of such storage.

java.net.ConnectException: Failed to connect to localhost/
Did you find the reason for this exception?

Hi All,

I am able to successfully launch http://localhost:9000 and see the Spinnaker hello message.

I have a tunnel set up for the port 8084 for Gate using Putty with localhost:8084, but it keeps complaining that the Gate end point is not accessible when I try to “Create Application”

I have Tunnels set up for the following in my Putty instance

port 9000, localhost:9000
port 8084, localhost:8084
port 8084, localhost:8087

Please provide some help and insight into the Gate end point not accessible issue.

Thank you,

Hi All,

I was able to get the “Create Application” to open by issuing the command ssh -L 8084:localhost:8084 ubuntu@ -i <key-file.pem>

Now, I have installed MySQL and Chaos Monkey.

However, when I click on “Create Application” from Deck UI, clicking on the Create button goes in a loop.

Please provide some suggestions on how to get this working.

Thank you,

hi @jamalhameed, did you see the above about setting up front50 so that deck can store/save your applications?

Hi @shaftdiesel, I was able to debug to find out that front50 is failing due to the lack of storage device.

However, I do have Minio storage server running in my virtual server instance.

Do you know what could be causing front50 to fail?

Thank you,

Hi All,

I am running into the same issue. The front50 service keeps failing for me.

SERVICE | - | PORT | - |
| spinnaker (deck) | - | 9000 | OK |
| redis | - | 6379 | OK |
| cassandra | - | 7199 | OK |
| thrift (cassandra) | - | 9160 | OK |
| clouddriver | OK | 7002 | OK |
| echo | OK | 8089 | OK |
| front50 | FAIL | 8080 | FAIL |
| gate | OK | 8084 | OK |
| igor | OK | 8088 | OK |
| orca | OK | 8083 | OK |
| rosco | OK | 8087 | OK |

Could someone provide suggestions on this? There is an external storage configured (Redis)

Thank you,

Hi All,

I have now enabled the property “chaosenabled = true” in the settings.js file locaked at /opt/deck/html/.

I have restarted Spinnaker service using “sudo service spinnaker restart”, but I do not see the link “Chaos Monkey” under Config section of my application.

Could you please let me know of suggestions to getting this working?

Thank you,

@jamalhameed, how do you get this nice output for the current status of the spinnaker services?