Spinnaker and jenkins debug


#1

Following this manual https://www.spinnaker.io/setup/ci/jenkins/

and I don’t see jenkins account showing up.

I am using kubectl apply -f https://spinnaker.io/downloads/kubernetes/quick-install.yml on our GKE cluster

and use version 1.7.0

any hints how to debug it? (maybe hit some rest endpoint to see if a service got the account right…)

One thing I notices that Igor service is not present at all in the namespace. maybe it has something to do with that?


#2

Have you included the configuration for your Jenkins instance in the halconfig ConfigMap that you deployed? The default deployment you’ve linked to has:

        jenkins:
          enabled: false
          masters: []

It also looks like igor might be disabled by default:

data:
  igor.yml: |
    enabled: false
    skipLifeCycleManagement: true

Maybe flipping that to enabled: true will work? (Not sure if that would be enough, or if there is other configuration that would be needed.)

Hope this helps!


#3

I setup jenkins (I login into hal pod created by that install script and configure it).

but haven’t setup igor. browsing those confugs I also noticed that it is disabled. I didn’t find any documentaion/forum post that igor has to be enabled somehow. is there any doc I can follow? or just go and try to set it to enable?

data:
igor.yml: |
enabled: false
skipLifeCycleManagement: true


#4

@ezimanyi, yep, enabling igor was the trick! I see my jenkins account. Thanks a bunch!

since hal container in GKE now runs under spinnaker not root (can’t install an editor). I run this command (i.e. toggled both flags)

cat << EOF > /home/spinnaker/.hal/default/service-settings/igor.yml
enabled: true
skipLifeCycleManagement: false
EOF

#5

Great, glad that worked—and thanks for posting an update here!


#6

I tried the above procedure but when I tried to run : hal deploy apply , on hal pod, I got the below error: home/spinnaker/.hal/default/install.sh must be executed with root permissions; exiting
! ERROR Error encountered running script. See above output for more
details. I’m following the procedure : kubectl exec -it cd-spinnaker-halyard-0 – bash , hal config ci jenkins enable , hal config ci jenkins master add my-jenkins-master --address “http://35.203.58.242:8080” --username admin --password and then: hal deploy apply

Do you know what is the problem ? what is the root password in hal pod ?


#7

@Hoa_Huynh in the ~/.hal/config file add this block with the exact details
ci:
jenkins:
enabled: true
masters:
- name:
address:
username:
password:
csrf: true

issue the command hal deploy apply
it should work for sure