Script stage errors unable to find master


#1

I have been trying to get a Script stage configured correctly in my pipeline.
I can never seem to get past the error: “Master ‘master’ not found”
My script is in a GitHub repo, and I have tried a number of different configurations to discover the repo and script, but nothing seems to get me past the error.


#2

The Script stage actually runs the script in Jenkins job. The “master” reference you’re seeing is the failure to find a Jenkins instance to run it in. You can find more info on how to set this up on the jenkins docs.

Relatedly, another option is to do a “Run Job” stage, which allows you to execute an arbitrary container. The point in both situations is to have a reasonable sandbox environment to run arbitrary stuff.


#3

At first it was not clear to me that there was a dependency on Jenkins. I realized that later in the day.
And then I ran into a bug with my version of Spinnaker where I could not have both Travis-CI and Jenkins in the configuration.
Once I added Jenkins to the configuration the Travis-CI configuration reported an error and prevented Igor from starting.

As a side, I never did have success with halyard and Spinnaker. I tried multiple times and never ended up with a working instance. I ended up using Armory to stand it up.


#4

Sure, Armory is a great option too. If you’re ever in a situation to pick up halyard installs again, please post here with halyard error details. Thanks, good luck.