Orca vs. Aurora


#1

Hey folks,
I’m trying to configure Orca for AWS Aurora, instead of using only redis(Elasticache).
Parameter groups, schema and DB users has been set up.
Orca profile added.
Everything done as described here: https://www.spinnaker.io/setup/productionize/persistence/orca-sql/
However Orca fails to start up.

Everything was working fine with Elasticache redis before I tried adding Aurora.
I have no idea where to look. Please see Orca’s logs in the snippet.
Would really appreciate it if somebody could give me a hint on where to start.

Orca seems to connect to the DB and it created the tables necessary for them, see:

mysql> show tables;
+-----------------------+
| Tables_in_orca        |
+-----------------------+
| DATABASECHANGELOG     |
| DATABASECHANGELOGLOCK |
| correlation_ids       |
| healthcheck           |
| orchestration_stages  |
| orchestrations        |
| pipeline_stages       |
| pipelines             |
+-----------------------+
8 rows in set (0.00 sec)

Versions:
Spinnaker: 1.12.3
Orca: 2.3.1
Aurora engine: 5.7.12
Elasticache redis: 4.0.10

.hal/default/service-settings/redis.yml

overrideBaseUrl: redis://aws-elasticache-redis-123.123123.0001.use1.cache.amazonaws.com:6379
skipLifeCycleManagement: true

.hal/default/profiles/gate-local.yml

redis:
  configuration:
    secure: true

.hal/default/profiles/orca.yml

sql:
  enabled: true
  connectionPool:
    jdbcUrl: jdbc:mysql://aws-aurora-123.cluster-123.us-east-1.rds.amazonaws.com:3306/orca
    user: orca_service
    password: 123123
    connectionTimeout: 5000
    maxLifetime: 30000
    # MariaDB-specific:
    maxPoolSize: 50
  migration:
    jdbcUrl: jdbc:mysql://aws-aurora-123.cluster-123.us-east-1.rds.amazonaws.com:3306/orca
    user: orca_migrate
    password: 123123

# Ensure we're only using SQL for accessing execution state
executionRepository:
  sql:
    enabled: true
  redis:
    enabled: false

# Reporting on active execution metrics will be handled by SQL
monitor:
  activeExecutions:
    redis: false

Please see the logs here:
https://pastebin.com/SGDN0bYA


#2

I added redis.connection, then it started to cry for other things, so I would had to reconfigure orca manually instead of it getting supplied by halyard, so basically I just renamed my orca.yml to orca-local.yml so just the settings I supplied gets overwritten, everything else is supplied by halyard, now it seems to work fine, should be updated in the docs, can be really itchy