Mixed content between deck and gate

#1

Hi,

I have configured spinnaker successfully on GKE and I am now making it public and adding SSL.

I have followed the following links to do so:

and

What I do however find is that accessing the UI and being redirected to login the spinnaker ui is pointing to the http version of the api and not the https version, see below screenshot.

I have double checked that both the following settings both point to the https version but I still get this error:

hal config security ui edit \
    --override-base-url https://spinnaker.$DOMAIN

hal config security api edit \
    --override-base-url https://spinnaker-api.$DOMAIN

Perhaps someone else have experienced this or could advise where I can start to debug this. I have double checked the ~/.hal/config file and all links point to the https version.

0 Likes

#2

After going through al the configurations and verifying everything is correct, I noticed the settings.js file still pointed to the old non https version when I inspected it in the browser. I also verified that the settings.js file stored in the kubernetes secret for the deck pod has the https prefix. In the end it turned out that our proxy was caching the JS file and that newer versions of the js files dit not reflect because of this. I had to clear the proxy cache which resolved this issue.

0 Likes