Kubernetes Source To Prod


#1

After a successful deployment I would like to follow this guide to deploy my sample app to my dev k8s cluster:

  1. Create a load balancer

At this point I should see a list of accounts in the drop down however the list is empty.

Deployment seemed to be successful:

sszabo@tor976568e1 [/home/sszabo] $ hal deploy apply
+ Get current deployment
  Success
+ Prep deployment
  Success
Problems in default.provider.kubernetes.dev-kube:
- WARNING Kubernetes accounts at V1 do no support configuring
  caching behavior for kinds or custom resources.

Problems in default.security:
- WARNING Your UI or API domain does not have override base URLs
  set even though your Spinnaker deployment is a Distributed deployment on a
  remote cloud provider. As a result, you will need to open SSH tunnels against
  that deployment to access Spinnaker.
? We recommend that you instead configure an authentication
  mechanism (OAuth2, SAML2, or x509) to make it easier to access Spinnaker
  securely, and then register the intended Domain and IP addresses that your
  publicly facing services will be using.

+ Preparation complete... deploying Spinnaker
+ Get current deployment
  Success
+ Apply deployment
  Success
+ Deploy spin-clouddriver
  Success
+ Deploy spin-front50
  Success
+ Deploy spin-orca
  Success
+ Deploy spin-deck
  Success
+ Deploy spin-echo
  Success
+ Deploy spin-gate
  Success
+ Deploy spin-igor
  Success
+ Deploy spin-rosco
  Success
+ Run `hal deploy connect` to connect to Spinnaker.


sszabo@tor976568e1 [/home/sszabo/tmp] $ kubectl get pods
NAME                                    READY     STATUS    RESTARTS   AGE
spin-clouddriver-bootstrap-v000-wvgm6   1/1       Running   0          1d
spin-clouddriver-v000-4pm79             1/1       Running   0          1d
spin-deck-v000-f5fff                    1/1       Running   0          1d
spin-echo-v000-l8zxf                    1/1       Running   0          1d
spin-front50-v000-8lpkk                 1/1       Running   0          1d
spin-gate-v000-xv6bg                    1/1       Running   0          1d
spin-igor-v000-dm7gd                    1/1       Running   0          1d
spin-orca-bootstrap-v000-njnr6          1/1       Running   0          1d
spin-orca-v000-mgs99                    1/1       Running   0          1d
spin-redis-bootstrap-v000-cbl5q         1/1       Running   0          1d
spin-redis-v000-7l4f4                   1/1       Running   0          1d
spin-rosco-v000-mzlx4                   1/1       Running   0          1d
webapp-7fbdd4b454-dtswp                 1/1       Running   0          34m

From hal config:

  kubernetes:
    enabled: true
    accounts:
    - name: dev-kube
      requiredGroupMembership: []
      providerVersion: V1
      permissions: {}
      dockerRegistries:
      - accountName: nexus-docker-registry
        namespaces: []
      context: dev-kube
      configureImagePullSecrets: true
      namespaces:
      - spinnaker
      omitNamespaces: []
      kinds:
      - spinnaker
      omitKinds: []
      customResources: []
      kubeconfigFile: /home/sszabo/.kube/config.yml
      oauthScopes: []
      oAuthScopes: []
    primaryAccount: dev-kube

#2

I was able to redeploy using:

hal config provider kubernetes account add dev-kube --provider-version v2

This seems to work, I’m able to list my kube account from the spinnaker ui.