How to silence bootstrap service logging via Halyard?


#1

How can I silence the bootstrap services from Halyard (on K8s)? I created a clouddriver-bootstrap-local.yml and a spinnaker-local.yml that both get deployed on the spin-clouddriver-bootstrap pod (in /opt/spinnaker/config, not in /opt/clouddriver/config) but I still get all the spammy INFO logging from the bootstrap pod.

Content of both *-local is

logging:
  level:
    com.netflix: WARN

Directory listing:

bash-4.3# ls /opt/spinnaker/config/
clouddriver-bootstrap-local.yml  clouddriver-bootstrap.yml        spinnaker-local.yml              spinnaker.yml
bash-4.3# ls /opt/clouddriver/config/
clouddriver.yml

#2

The same happens to me. For “normal” pods (clouddriver, front50, orca etc) this approach works. But for clouddriver-bootstrap and orca-bootstrap it does not, precisely as described by @mmlac.


#3

Alright, I got that working by including this into my service-settings/clouddriver-bootstrap.yml

env:
  SPRING_PROFILES_ACTIVE: "bootstrap,bootstrap-local"

The thing is that by default those bootstrap pods (orca-bootstrap and clouddriver-bootstrap) have only one profile active SPRING_PROFILES_ACTIVE: bootstrap. Because of that the corresponding -local file is ignored.


#4

The fix was applied in upstream: https://github.com/spinnaker/spinnaker/issues/2635. So with future versions of halyard it should work out of the box.