Halyard deploy apply doesn't redeploy all components


#1

Hi all,

We’re running Spinnaker 1.11.4 running on 1.10.11-gke.1 with halyard using the V2 providers and we’re using the “HA setup”.

I run hal deploy apply quite frequently (to update k8s resource usage, add/remove provider account etc)

I’m sometimes seeing that when I run halyard, not all components are redeployed. I can see in the halyard logs that all services are listed for deployment but kubernetes does not do anything for some of the services.

For example clouddriver (ro, ro-deck,rw,caching), echo and gate are always redeployed, but for example orca, fiat and deck are not.

Is there a way for me to force a deployment of all components? Is it all just a kubernetes problem or can I do something in halyard?


#2

I’m guessing what’s happening is that Kubernetes is not recycling pods if nothing has changed at all for a particular deployment. I don’t think there’s a way for Halyard to somehow force Kubernetes to recycle all Spinnaker pods, even if nothing has changed. (But maybe someone else has found a way to do this.)