Error Setting up authentication


#1

I am following the https://www.spinnaker.io/setup/security/authentication/. I am running into an issue when enabling authentication get authentication <gate url/auth/user get request. the deck url is replaced with another URL, hence failing. Spinnaker is deployed into Kubernetes, so there is no standalong apache confugyration that I could change, e.g. ports.conf spinnaker.conf.

I am enabling LDAP.

When I correctly mention the gateurl /auth/user I do get the LDAP logon screen and prompted to enter my LDAP credentials and it is successful. Any steps how to resolve this via halyard\ profile\ service setting will be appreciated.

Erez Har-Tal
DevOps Engineer
Walgreens Boots Alliance


#2

Hi Erez,

Could you describe a bit more what happens when you see the Deck URL replace with another URL? Is your browser redirected or do you see an AJAX request hitting the wrong endpoint in your browser console?

You can configure Deck to use a specific Gate URL by setting the API_HOST environment variable and restarting the Deck service. By default that URL is set to http://localhost:8084

If this doesn’t resolve your issue then please provide some more info about the URL you expect vs the URL you are redirected to and I will try to figure out what’s going wrong.

Thanks!
Scott


#3

It sounds like you’re encountering this bug: https://github.com/spinnaker/spinnaker/issues/2524

I’ve written a workaround in there.