ERROR 409 while configuring minio using hal for setting up Spinnake


#1

I am trying to configure Spinnaker on an on-premise RHEL VM with no internet connection. I am following this link and doing the necessary adjustment for this:

I have reached till Docker registry and Mino persistent storage now when I am trying to configure internal persistent store(Not AWS or any external) for Spinnaker with mino. For this I did the following:

  1. Installed Halyard container
  2. Installed Mino as container: I am able to acccess it through chrome with same credentails that I have given in the command, created a bucket and also uploaded an image. All through chrome browser.
  3. Tried to configure it using hal config storage command to use the same Minio instance for internal storage then this error is thrown.

export ENDPOINT=http://172.17.0.3:9000
root@hal-2422273360-8fjph:~# echo $MINIO_SECRET_KEY | hal config storage s3 edit --endpoint $ENDPOINT --access-key-id $MINIO_ACCESS_KEY --secret-access-key --debug
Your AWS Secret Key.: —> HTTP GET http://localhost:8064/v1/config/currentDeployment/
—> END HTTP (no body)
<— HTTP 200 http://localhost:8064/v1/config/currentDeployment/ (307ms)
X-Application-Context: halyard:test,local:8064
Content-Type: application/json;charset=UTF-8
Transfer-Encoding: chunked
Date: Mon, 05 Nov 2018 11:28:13 GMT
OkHttp-Sent-Millis: 1541417293171
OkHttp-Received-Millis: 1541417293187

{
“name” : “Get current deployment”,
“timeout” : 60000,
“events” : ,
“children” : ,
“uuid” : “3dd481dd-2336-4670-bddd-22aab1164756”,
“timedOut” : false,
“version” : “1.12.0-20181024113436”,
“state” : “SUCCEEDED”,
“response” : {
“responseBody” : “default”,
“problemSet” : {
“problems” :
}
},
“fatalError” : null,
“runningJobs” :
}
<— END HTTP (385-byte body)
—> HTTP GET http://localhost:8064/v1/tasks/3dd481dd-2336-4670-bddd-22aab1164756/
—> END HTTP (no body)
<— HTTP 200 http://localhost:8064/v1/tasks/3dd481dd-2336-4670-bddd-22aab1164756/ (3ms)
X-Application-Context: halyard:test,local:8064
Content-Type: application/json;charset=UTF-8
Transfer-Encoding: chunked
Date: Mon, 05 Nov 2018 11:28:13 GMT
OkHttp-Sent-Millis: 1541417293327
OkHttp-Received-Millis: 1541417293329

{
“name” : “Get current deployment”,
“timeout” : 60000,
“events” : ,
“children” : ,
“uuid” : “3dd481dd-2336-4670-bddd-22aab1164756”,
“timedOut” : false,
“version” : “1.12.0-20181024113436”,
“state” : “SUCCEEDED”,
“response” : {
“responseBody” : “default”,
“problemSet” : {
“problems” :
}
},
“fatalError” : null,
“runningJobs” :
}
<— END HTTP (385-byte body)

{
“name” : “Get persistent store”,
“timeout” : 60000,
“events” : ,
“children” : ,
“uuid” : “7f39800c-4a2f-4286-afd7-d2b8ac00668b”,
“timedOut” : false,
“version” : “1.12.0-20181024113436”,
“state” : “NOT_STARTED”,
“response” : null,
“fatalError” : null,
“runningJobs” :
}
<— END HTTP (302-byte body)
—> HTTP GET http://localhost:8064/v1/tasks/7f39800c-4a2f-4286-afd7-d2b8ac00668b/
—> END HTTP (no body)
<— HTTP 200 http://localhost:8064/v1/tasks/7f39800c-4a2f-4286-afd7-d2b8ac00668b/ (2ms)
X-Application-Context: halyard:test,local:8064
Content-Type: application/json;charset=UTF-8
Transfer-Encoding: chunked
Date: Mon, 05 Nov 2018 11:28:13 GMT
OkHttp-Sent-Millis: 1541417293379
OkHttp-Received-Millis: 1541417293380

{
“name” : “Get persistent store”,
“timeout” : 60000,
“events” : ,
“children” : ,
“uuid” : “7f39800c-4a2f-4286-afd7-d2b8ac00668b”,
“timedOut” : false,
“version” : “1.12.0-20181024113436”,
“state” : “SUCCEEDED”,
“response” : {
“responseBody” : {
“bucket” : null,
“rootFolder” : “front50”,
“region” : null,
“endpoint” : null,
“accessKeyId” : null,
“secretAccessKey” : null
},
“problemSet” : {
“problems” :
}
},
“fatalError” : null,
“runningJobs” :
}
<— END HTTP (543-byte body)

{
“responseBody” : null,
“problemSet” : {
“problems” : [ {
“message” : “Error creating the directory ?/.hal/default/config: Error creating the directory ?/.hal/default/config with unknown reason.”,
“remediation” : null,
“options” : null,
“severity” : “FATAL”,
“location” : “Global”
} ]
}
}
<— END HTTP (333-byte body)
! ERROR 409
? Try the command again with the --debug flag.

Please help. I am facing exact issue: 409 error while configure the internal docker registry using the command hal config provider docker-registry account add my-docker-registry
–address $ADDRESS
–repositories $REPOSITORIES.

For both Minio and Docker registry I am facing this issue. Keep in mind that I don’t have internet access form this RHEL VM where I am setting up Spinnkaer, I am manually transferring all the docker images(Store and Load) and then using them. Please help …