Doing something stupid with Artifacts, but can't tell what

Hi all,

I’m having some difficulty getting Artifacts to bind in my Deploy (Manifest) stages.

I have a very simple Pipeline with a webhook trigger that I am posting some base64 encoded Kubernetes Manifests to.

In the first stage of my Pipeline, I deploy the Config Map artifact, that is being deployed by Spinnaker to myconfigmap-v000. So far so good.

In the second state I deploy the ReplicaSet artifact. This fails to stabilize with a "can’t find configmap myconfigmap" error). I have tried using various references to the configmap (envFrom/configMapRef, valueFrom/configMapKeyRef etc). I believe the configmap reference should be successfully replaced in them, (looking at the lwander/spin-kub-v2-demo manifest for example) but the error messages aren’t helping me determine what I’ve done wrong.

If I look at the YAML source for the pipeline failure, I can see that there is indeed a kubernetes artifact bound:

{
  customKind: false,
  reference: "myconfigmap-v000",
  metadata: {
   account: "secret"
  },
  name: "myconfigmap",
  location: "secret",
  type: "kubernetes/configMap",
  version: "v000"
}

I think I’ve done everything according to the docs, but there seems to be no way to “bind” the generated Kubernetes artifact from stage1 in stage2 so I’m not sure that’s needed?

Have I just missed something super obvious?

Thanks!

To add, I’ve tried to put the configmap and the replicaset in the same artifact and just deploy that but also no luck

Well, I was doing something stupid - I’d put the name of the artifact in the YAML instead of the name of the configmap. It seems to be working properly now!