Deck doesn't restart after reboot?


#1

I had a (seemingly) fully functional Spinnaker 1.6.0 install on Ubuntu 14.04 with Kubernetes and S3. I created a simple application and that all worked.

Then I rebooted the server.

Now I can’t create an application, and the errors in the console (there are no logs on the server I can find) are listing URLs on port 8084. When I try to hit those URLs, it comes up as unable to connect.

Is this normal? Is there a way to fix this? I tried running hal deploy apply and that didn’t work. I tried running hal deploy connect but it’s locally installed so it just tells me there’s nothing to do.

Help!

Thanks…

---- Nick


#2

The errors on the console would indicate that your browser can’t connect to the Gate microservice (which listens on port 8084). This could be one of two things:
-The port isn’t accessible to your browser (either due to a firewall, or because you’re using port forwarding and only forwarded port 9000)
-There’s some error preventing the Gate microservice from starting. In this case, you should be able to see the error in /var/log/spinnaker/halyard/halyard.log, which we can use to further debug.

-Eric