Could not resolve Google account: (account_name=null)


#1

Hi,
When trying to run a pipeline with a bake stage I’m getting the following error: Could not resolve Google account: (account_name=null).
I assumed that the account name configured for google provider like below will be used by rosco service.
hal config provider google account add my-gce-account --project…
I didn’t change anything in the /opt/rosco/config/packer/gce.json file and in the /home/spinnaker/.hal/default/profiles/rosco.yml I enabled google and added a repo url and image details.
Can’t find any additional steps in Spinnaker docs that would explain what I’m missing.
Thank you.


#2

Please disregard, seems like the custom config file that i had in /home/spinnaker/.hal/default/profiles/rosco.yml
had to include all the data that the original file in /opt/spinnaker/config/rosco.yml had besides my custom stuff.
It works after I copied the original file to the ~/.hal/default/profiles/ location and added the custom configuration to it.
Still not clear to me why there is a rosco.yml in both /opt/rosco/config and /opt/spinnaker/config however.