Cannot remove reference to Kubernetes cluster that no longer exists


#1

Hi, I am trying to delete a reference to a kubernetes cluster that no longer exists, when I try to delete the account using halyard I recieve an error suggesting it cannot be deleted because halyard cannot connect to the cluster, this is a bit of a catch 22 situation, can anyone suggest another way to remove the cluster from halyard? thanks

I ran the following command:
hal config provider kubernetes account delete collect-prod0
and received the following error:

  Success
- Delete the collect-prod0 account
  Failure
Problems in default.provider.kubernetes.collect-test0:
! ERROR Unable to communicate with your Kubernetes cluster:
  Operation: [list]  for kind: [Namespace]  with name: [null]  in namespace:
  [null]  failed..
? Unable to authenticate with your Kubernetes cluster. Try using
  kubectl to verify your credentials.```
  I also get the same error running hal deploy apply.

We cannot currently access the spinnaker cluster, i suspect due to this issue.

Thanks in advance for any ideas on this

#2

Run the command with the --no-validate flag.