Bake(Manifest) with HELM2 Overrides doesn't work with booleans

#1

I am trying to use charts with different sets of values for each environment by using the requirements.yaml to import values from sub-charts.
This requires passing a boolean so that values from a specific sub-chart are loaded.
It works when rendering using helm on the command line like this:
helm template nginx --set tags.dev-values=true
However when setting overrides in Spinnaker I get the following error:
Warning=Tag ‘dev-values’ for chart nginx-dev returned non-bool value
I checked the logs and it looks like rosco is running the helm command with --set-string option which converts all values to strings including booleans, see here https://github.com/helm/helm/pull/4142
I know that feeding an override file with values is an option but that means I have to maintain 4 files per application outside the helm package which kind of defeats the purpose of packaging.
Is there a workaround for this, or am I missing something in Spinnaker docs?

1 Like
#2

Did you ever find a valid workaround for this? Right now I have a totally separate values.yaml that contains just the boolean set to false and I only use it in spinnaker.